Troubleshooting VMware

ESXi 6.0 and 6.5 PSOD when running pktcap-uw

The pktcap-uw tool is an enhanced packet capture and analysis tool that can be used in place of the legacy tcpdump-uw tool. The pktcap-uw tool is included by default in ESXi 5.5 and later versions.

It was detected that running a packet capture on ESXi 6.5 hosts will cause a PSOD. This issue is known already by VMware and resolved in patch to be released in the next days of September 2018 but recently we discovered same issues are experienced by ESXi 6.0 hosts.

Fix for version 6.0 hosts will be upgrading to 6.5 and apply patch to be released. For those cases where your platform does not support 6.5 as per compatibility matrix or maybe your are not ready to run vSphere 6.5 simply avoid using packet capture in the host and try to do it at physical switch or firewall so you can avoid below.

Details on how to use packet capture here